「Media」の版間の差分
(Other Window) |
(書き出し設定のプリセット) |
||
| (同じ利用者による、間の1版が非表示) | |||
| 90行目: | 90行目: | ||
VideoのResolution。元動画576x360だが、これにするとぼやける。コーデックがh264だからだろう。libvpx-vp9を選ぶと失敗する。やむを得ない。 | VideoのResolution。元動画576x360だが、これにするとぼやける。コーデックがh264だからだろう。libvpx-vp9を選ぶと失敗する。やむを得ない。 | ||
==== 書き出し設定のプリセット ==== | |||
カスタマイズした書き出し設定を毎回手動入力するのが面倒。保存して流用できる。 | |||
https://x.com/i/grok/share/ed834bedf5cb4005b5a757c44e0bdab2 | |||
# [書き出し] を選んで書き出したい設定にする。 | |||
# [プリセット] の左下の [+] を選ぶ。 | |||
# 任意の名前を指定して保存する。 | |||
書き出し時のファイル名に日本語があると反映されないので注意する。 | |||
書き出した設定ファイルは、[設定]-[App データフォルダ] から確認できる。 | |||
~/Library/Application Support/Meltytech/Shotcut/presets/encode に格納される模様。テキストファイルなので直接編集してもOK。Shotcutを再起動しなくても、プリセットを選ぶと反映される。 | |||
=== Filter === | |||
==== 音量調整 ==== | |||
[https://jp.videoproc.com/edit-convert/how-to-change-volume-gain-in-shotcut.htm Shotcut使い方:音量調整|フィルタ・フェードイン/アウト・キーフレームで動画・音楽ファイルの音量を調節する] | |||
# 対象音声をタイムラインから選択。 | |||
# [フィルター]-[ゲイン・音量] | |||
これで音量を調整可能。 | |||
[[Category:IT]] | [[Category:IT]] | ||
2026年9月23日 (水) 01:30時点における最新版
About
Mediaファイル関係の情報をまとめる。量が増えたら別ページに分割する。
Format
Image
画素数とファイルサイズ
Ref: 画像ファイルの解像度、画素数、データ容量について | デジアカ.
画素数pxとbitの計算式がある。
まず、1px=1bitだが、ここに色の考慮がある。
- フルカラー=RGBの3系統がそれぞれ8bit=256階調の色があるので24bit
- グレー=、4ビット16階調、8ビット256階調で表現した画像ファイルがあります。4ビットでは2の4乗で16通りになり、8ビットでは2の8乗で256通り。
画素数*色数=ファイルサイズ [bit]。
例えば、345x345pxのカラー画像。
345*345px * 24bit / 8 bit/Byte = 357075 Byte =357 KB。
GIMP
About
GIMPは自由な画像編集ソフト。
Color
色の変更
キャンバスの色も変更できる。色の選択、塗りつぶしの2段階の操作になる。
- ツールボックスの背景色を変更。
- [Edit]-[Fill with FG Color]/[Fill with BG Color]
これで色が変わる。
Text
align
テキスト・文字を上下・中央に揃える (GIMP – 文字を縦・横で中央寄せしてセンターに揃える方法 | Howpon[ハウポン])。
- [Tools]-[Text] (左パネルのAマーク) (t) を選んで任意のテキストボックスを作成して文字を入力する。
- 左パネルで [Box]=[Fixed] になっているので、[Dynamic] に変更する。
- [Tools]-[Transform Tools]-[Align] (左パネルの棒チャートマーク) (q) を選で整列させる。
Other
Window
Shotcut
About
Shotcutは自由な動画編集ソフト。クロスプラットフォームでWindows/Mac/Linuxで動作する。
Timeline
タイムラインを右クリックすると、タイムラインを追加できる。これで、動画の上に画像を重ねたりできる。
Export
編集したした動画をファイルに出力する。
[View]-[Export] を選ぶと [Export] ペーンが表示される。
左端の [Presets] に用途別のデフォルトが用意されている。[YouTube] があるので通常はこれを選べばいい。
ただし、解像度が大きすぎる。
[Advanced] から詳細設定できる。
素材に合わせてひとまず以下を選ぶ。
- Video
- Resolution=1280x720
- Frames/sec=8
- Codec
- Codec=h264_videotoolbox
- Audio
- Channels=1
- Bitrate=32k
最後に、[☑Use hardware encoder] を選んでおく。これを選ぶと、出力が早くなる。
最後に [Export File] を選ぶ。
動画のエンコード・出力が始まる。右端の [Jobs] ペーンで進捗がわかる。
元ファイルより条件を低くすると劣化する。
VideoのResolution。元動画576x360だが、これにするとぼやける。コーデックがh264だからだろう。libvpx-vp9を選ぶと失敗する。やむを得ない。
書き出し設定のプリセット
カスタマイズした書き出し設定を毎回手動入力するのが面倒。保存して流用できる。
https://x.com/i/grok/share/ed834bedf5cb4005b5a757c44e0bdab2
- [書き出し] を選んで書き出したい設定にする。
- [プリセット] の左下の [+] を選ぶ。
- 任意の名前を指定して保存する。
書き出し時のファイル名に日本語があると反映されないので注意する。
書き出した設定ファイルは、[設定]-[App データフォルダ] から確認できる。
~/Library/Application Support/Meltytech/Shotcut/presets/encode に格納される模様。テキストファイルなので直接編集してもOK。Shotcutを再起動しなくても、プリセットを選ぶと反映される。
Filter
音量調整
Shotcut使い方:音量調整|フィルタ・フェードイン/アウト・キーフレームで動画・音楽ファイルの音量を調節する
- 対象音声をタイムラインから選択。
- [フィルター]-[ゲイン・音量]
これで音量を調整可能。
